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What steps do I follow to create a MobileMapper background 
map? 
You can read about creating a MobileMapper Background map in the User Manual that 
accompanies MobileMapper Office software.  But here are a few quick steps: 

1. On the menu bar, select Tools and then Background Map. This opens the 
Background Map window. 

2. Click on the Create New... button. This opens the Create Map window from 
which you can create a new background map 

3. Type in a name for the background map in the Map Name field. 
4. In the Map Scale field, choose a scale value above which this background map 

will NOT be displayed on the Map Display area or on the handheld screen. (This 
is used to hide the background map when the current scale value of 
MobileMapper Office’s map display area or on the handheld’s map screen is 
incompatible with the extent of this background map.)  It is recommended to use 
the default scale 1:100,000 or less (e.g. 1: 50,000), especially for big maps, to 
speed up map display. 

5. Click on Layer > Add to add a layer to your map.  This displays a browsing 
window. 

6. Go to the directory where you have stored the file that you want to insert as a 
layer in the background map. 

7. In the Files of type field click on the format of the file that you want to add. 
8. Click on the file name you want to add. 
9. You MUST select the coordinate system that the file is in.  MobileMapper cannot 

import a file into a background map without first knowing what coordinate 
system/datum the file is in. You can use your GIS to determine what this 
coordinate system/datum might be, if you do not already know. 

10. Click on Open to add this file as a layer to the background map. 
11. The may symbol that will be used to display this layer is indicated on the Create 

Map window.  You can select other symbols, line attributes, colors, etc. by 
double-clicking on the layer name. 

12. Select other layers you want to add to the background map, if any.  You can select 
which layers will be displayed on top of the other layers by using the Layer > 
Move Up and Move Down commands. 

13. When you are done adding layers, select File and then Save or Save As. In the 
dialog box that opens, choose a folder and enter a name for the background map 
file you want to create. This file will have the “mmp” extension. 

14. Then click Operations > Create Map to create the file. 
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15. After the new map has been created, click on File > Exit to return to the 
Background map window. 

16. The new map is highlighted (there is a paper clip icon next to it).  Click on Close 
and the background map should be displayed. 

 
When I try to create a background map I see an error message 
telling me that the map name cannot contain a layer name and 
one layer name cannot contain the name of another layer.  
What does this mean? 
With MobileMapper 1.10, if one of the layers that you have included in the background 
map is named “Streets,” you cannot enter “Streets” in the Map Name box on the Create 
Map window.  Select another name for the map. 
Also, if one of the layers that you have included in the background map is named 
“Streets,” you cannot add another layer called “Streets2” in the same map. Delete the 
layer whose name contains another layer’s name, in this case, delete “Streets2.”  The 
click on the Add a Layer icon, right-click on Streets2, rename it something like “Str2” or 
“Roads,” press Enter and click on the new name to add this renamed layer.  You may 
want to make a note of this change to remind you that the background map contains a 
renamed layer. 
 
How do I select the background map I want to open? 
When you select Tools > Background Maps, you see a window that lists all the 
background maps that you have created.  (The first time you open this tool it will of 
course be empty.)  To select a map, just click on its name and then click on the Attach 
button.  This will cause a paper clip icon to appear next the name.  When you click on the 
Close button, you should see the map on the map screen.  You can also detach a selected 
map 
 
What do I do if I already see a background map in 
MobileMapper Office and I want to remove it? 
Select Tools > Background Maps and click on the Detach button.  This will remove the 
paper clip icon next the name.  When you click on the Close button, there will not be any 
background map displayed on the map screen. 
 
I uploaded a background map to the MobileMapper receiver and 
the software told me it couldn’t connect to the unit on COM1.  
How do I overcome this issue? 
Click on the Upload Wizard’s Settings button, highlight the COM1 on the settings 
window and click Test.  When the utility finds the receiver, click OK and click on the 
Next button on the Upload Wizard-Checking GPS window.  If MobileMapper Office still 
cannot find the receiver, your PC’s COM1 port is probably reserved by another 
application – even one that is running in the background.  You must disable this 
application’s communication on the COM1 port. 
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What should I do if I see the world map instead of the selected 
background map? 
This can occur for many reasons.  These are the most common causes: 
- The GIS file you imported to create the map was in a different coordinate 

system/datum from the one you indicated upon import  
- The job file and the background map are in different locations and their extents do 

not overlap 
- The background map is corrupted for some reason and should be edited or 

regenerated 
 
I have attached the background map I want to display, but I 
cannot see it on the map screen.  How do I display it? 
All you have to do is zoom in to a scale that is larger than the scale you set for the 
background map when you created it.  For example, if you used the default scale 
1:100,000 in the Map Scale field of the Create Map window and if the scale of the map 
display screen is set at 1:100,001, you won’t see the background map. To reset the scale 
to a larger number (i.e. smaller ratio), click on View > Zoom In or on the Zoom In icon 
(a magnifying glass with a + symbol in it).  You can also click on the down arrow next to 
the Set Scale box in the icon bar and select the “Zoom to…” option at the bottom.  Then 
type in a number that is smaller than the scale number you selected in the Map Scale field 
of the Create Map utility. 
 
Why are background maps hidden when the current scale value 
of MobileMapper Office’s map display or the handheld’s map 
screen is smaller than the background map scale? 
When you are zoomed out beyond the scale of the background map, its usefulness is 
greatly diminished – especially if you are located outside the map’s extent.  By not 
displaying the background map when it is not a very useful too, we are able to improve 
map display performance. 
 
How do I edit a background map? 
You can also use MobileMapper Office’s Background Map module to edit existing 
background maps. To do this, select the Create New… option and then click on File > 
Open to select the name of the map you want to edit. 
After you have edited the file, remember to save it by clicking on File > Save.  Then 
press the Operations > Create Map option.   
 
What types of GIS files can I use to create a MobileMapper 
background map? 
As with MobileMapper job files, you can import ESRI shapefiles, MapInfo MIF files and 
Autodesk DXF files into a background map. However, in order to import the GIS file, 
you must tell MobileMapper Office what coordinate system and datum are used to 
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display the file, e.g. UTM North, Zone 14 WGS 84, lat-lon, etc. You can usually 
determine the coordinate system and datum of your GIS file by displaying it in your GIS. 
 
When I import a file to create a background map, I sometimes 
notice that the edges are “jagged” in appearance.  What causes 
this? 
MobileMapper background maps can be several megabytes in size, whereas job files are 
often measured in tens of kilobytes.  This means that the receiver’s map engine will take 
much more time to display a background map than a job file.  One way to improve 
background map display is to reduce its resolution.  Background maps are designed for 
display on the MobileMapper receiver where the maximum zoom level is around 1:3000, 
whereas job files are intended for ultimate display by a GIS where the maximum zoom is 
perhaps 1:100.  Clearly the resolution for a background map does not need to be nearly as 
high as for a job file. Because of this increased need to speed up display performance and 
the reduced need for resolution, we decided to set the resolution of MobileMapper 
background maps to one meter. When viewed at maximum zoom on MobileMapper 
Office’s map screen, one meter is 0.5 cm, which is quite visible.  However, when viewed 
on the receiver at maximum zoom, a one-meter jump in a line is not visible at all. 
 
Why is the selection of map symbols for point features in 
background maps different from the selection for feature 
libraries and job files? 
It is better to use two different sets of point symbols so you can distinguish a feature on 
the background map from a feature in a job file.  A feature on a background map is just a 
visible navigation and reference guide that is uneditable.  You would not want to confuse 
such a feature with a feature in a job file that is an editable, geo-referenced entry in a 
database.  
 
How do I upload a background map to the receiver? 
First you should restrict the amount of data make sure that the background map is 
displayed on MobileMapper Office’s map screen.  It makes no difference is a job file is 
simultaneously displayed.  Click on File > Upload to GPS and then click on 
Background Map.  If you have not selected a region, the entire background map will be 
uploaded.  You are then given a choice of uploading the map (1) directly to the receiver 
via the serial cable, (2) to the receiver’s SD card when it is placed in an SD card reader 
(this is much faster for large background maps) or (3) to a location on your PC’s hard 
drive.  If you select the SD card reader option, leave the card in the reader for 
approximately 30 seconds after MobileMapper Office indicates that the transfer is 
complete.  Some card readers require this extra time to save the uploaded file to the card 
even though the transfer is complete. 
 
How should I safely remove the SD card? 
You are strongly advised to use the Windows “Eject Hardware” utility in order to safely 
remove the SD card.  Move your cursor over the icons in the bottom right of your screen 
until you find the one whose pop-up window reads “Unplug or Eject Hardware.”  Click 
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on this icon and select the SD card reader.  You can also do this by clicking on the Start 
button and then Settings > Control Panel > Add/Remove Hardware. 
 
After I removed the SD card from the reader and put it back in 
my MobileMapper, the receiver began malfunctioning.  I can 
turn it on but it repeatedly indicates it needs to be reinitialized 
(but won’t let me do this) or it freezes up.  What should I do? 
The SD card is corrupted.  This may be due to any or all of the following: 

1. It was either removed from the SD card reader before files were saved properly. 
2. It was removed without using the Windows Eject Hardware utility. 
3. The card may be faulty in a way that is affecting the receiver and perhaps also the 

SD card reader.  It should be replaced. 
To fix a card that is not physically or electrically damaged, use the SD card reader to 
reformat the card and reload the background map and any other files you might want to 
install on it.  You can upload any files from your PC to the receiver by using the 
MobileMapper Transfer utility (File > Download from GPS).  When all the files you 
want are uploaded to the receiver, leave the card in the card reader for about 30 seconds 
before ejecting it with the Windows Eject Hardware utility.  Replace the card in the 
receiver and turn it on.  Ignore any request to initialize the receiver, press MENU > 
Setup > Clear Memory and clear all memory.  This turns off the receiver.  Turn it back 
on and re-initialize it.  The key to avoiding this in the future is to always use the 
Windows Eject Hardware utility prior to removing an SD card from the reader. 
 
How do I upload a region of a background map to the receiver? 
With the background map displayed, click on Tools > Create Map Region.  Then click 
and drag the cursor to create a rectangular subsection of the background map for upload.  
You will note that an approximation of the number of bytes comprised in this region is 
displayed.  When you are satisfied with the size and extent of this region, right click the 
mouse and the region will be filled.  This indicates that region has been created.  When 
you upload the background map to the receiver, the upload utility will ask if this is the 
region you want to upload. 
 
Uploading background maps takes a lot of time.  Is there any 
way to speed this process? 
1. The first thing you should do is to restrict the amount of data you want to upload to 

the receiver.  You do this by including in your background maps only those layers 
that you will need to use in the field. 

2. You can also dramatically decrease the upload time and simultaneously improve map 
display performance in the receiver by uploading the smallest necessary portion of a 
background map.  These subsets of MobileMapper background maps are called 
“regions.” When you upload a region instead of the whole map, you do not in any 
way affect the whole map.  It remains intact should you ever want to upload a 
different region.  The answer to the question immediate above this one tells you how 
to create a background map region. 
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3. The most effective way to upload a map to your receiver is by selecting the “Upload 
to SD Card” option after clicking on File > Upload to GPS > Background Map. 
Uploading to the receiver uses a serial connection that is inherently much slower than 
communicating with an SD card receiver that typically uses a USB connection.  
Uploading anything to the receiver is faster via an SD card reader. 

 
What types of file extensions are created when I upload a 
background map to the receiver? 
The background map upload process does not upload the file you created (with .mmp file 
extension).  Rather, the upload process reformats this map file to optimize its 
performance in the receiver.  The optimized map has an .img file extension.  To allow 
compatibility with Thales Navigation’s Magellan MapSend product, the .img file is 
automatically named DETAIL00.IMG.  Each will automatically receive it’s own 3-digit 
number in the file name.  This will allow you to upload a number of regions of the same 
background map and so use smaller amount of data at one time, thereby increasing map 
display performance. 
 
I uploaded one map to the receiver via its serial cable.  When I 
uploaded a second map via the cable, the first map was erased.  
Why did this happen? 
MobileMapper Office allows you to upload only one map at a time to the receiver via the 
serial cable.  If you upload map1.mmp via the serial cable it is automatically renamed 
DETAIL00.IMG on the receiver’s SD card.  If you then upload map2.mmp, it will be 
also be uploaded as DETAIL00.IMG and with overwrite the first map.  We did this to 
reduce the amount of memory taken up by background maps on the SD card.  For most 
customers this is not a problem because they use only one background map or only one 
for each field project. 
 
How do I upload multiple maps? 
You can upload multiple maps to the receiver by placing its SD card in an SD card reader 
and selecting the SD card reader option on the Upload Wizard.  Each file uploaded 
directly to the SC card keeps its original name but is given the .IMG extension. 
 
What is the difference between an .MMP file and an .IMG file? 
The .MMP format is optimized for display by MobileMapper Office.  An .IMG file is 
optimized for display by the MobileMapper receiver. 
 
I can see a rectangular outline on my MobileMapper receiver’s 
map screen.  What is this? 
This rectangle is called a background map extent frame.  It outlines the extent of a 
background map once it is uploaded to the receiver.  It is visible with all background 
maps in the receiver as a sort of picture frame so you can clearly see what portion of the 
map screen lies within the background map and what portion lies outside. 
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Why is this background map extent frame sometimes blank? 
If there is an error in creating a background map, it is possible to upload it to the receiver 
– together with its extent frame – but impossible to display it.  All you see is the 
rectangle.  In addition, some people have created background maps using white features.  
While these features appear on the colored MobileMapper Office map screen, they are 
invisible on the white receiver map screen. Either way, all you see on the receiver is a 
black rectangle with nothing inside. 
 
How can I remove the background map (and its extent frame) 
from the display? 
When you remove a background map from view, you also remove the map extent frame.  
On your receiver, press the Menu button and select the Setup option.  Move the cursor 
down to Select Map and press Enter. Highlight the Detail Map field and write down the 
name of the detail map.  Then press the Enter button and select the Detail Map Off 
option.  Press Enter again.  You will be on the Select Map screen again where you 
should highlight Save at the bottom of the screen and press Enter. 
 
How can I delete a background map (and its extent frame)? 
First remove the background map from the display (see the instructions in the previous 
question).  Press ESC and then the Menu button.  Now select the Delete Files option and 
delete the background map that was listed in the Detail Map field. 
 
How can I edit the background map? 
Use MobileMapper Office Background Map module to edit and re-create this map and 
then reload it into the receiver. Select the Create New… option and then click on File > 
Open to select the file name.  After you have edited the file, save it and press the 
Operations > Create Map option.  When you upload this new version of the map into 
the receiver, the old version (if you haven’t deleted it) will be overwritten.  If there are 
still problems with the map, you should start over and make sure of the coordinate system 
and datum of each layer you want to import. 


