
Steps to transfer a scanned topographical map to a Meridian 
 
Overview over the process: 
1. Scan the map 
2. Adjust and simplify the image with a program for image processing, here Adobe Photoshop. 
3. Create a vector-file with WinTopo (freeware). 
4. Import the vector-file into MMO (Mobile Mapper Office). Several turns are necessary to adjust the geographical 

position. 
5. Convert the MMO-output with convertMMOoutput.exe and copy it to the SD-card. 
6. The result is useful for easily determining the actual position on a map without having to juggle with 6 to 8-digit 

figures. But the source paper map is indispensable. Only by comparing the display with the source paper map you 
will know the exact position or will be able to set exact waypoints. 

 
Used Utilities: 
1. Scanner 
2. Program for image processing. I used Adobe Photoshop. Used features are 

• Distorting an image with exact values to compensate the influence of the scanner. 
• Raising the contrast by sharpening the image to get topographical lines recognized 
• Condense the contrast on areas of low interest to reduce the number and raise the expressiveness of vectors 
• Resize images 
• Saving images as BMP. 

3. Program to convert coordinates between systems (UTM -> Lat/Lon -> Swiss Grid…). I used ALLTRANS (Demo-
version under http://www.allsat.de, Downloads. This demoversion is sufficient) 

4. Program to convert a BMP-file into a vector file. I used WinTopo (Freeware-version available on 
http://www.wburrows.demon.co.uk/softsoft/wintopo/index.htm) 

5. Program to import and georeference a vector-file and produce a map usable with Magellan products = 
MobileMapperOffice = MMO, available at ftp://ftp.thalesnavigation.com/pub/software/. 

6. When using MMO 1.10: Program to convert MMO-generated maps (*.img) to Meridian-usable maps: 
convertMMOoutput.exe available at http://groups.yahoo.com/group/mapsend_format/files/Creator%20programs/. 
Many thanks to Mikhail, obelix662000@yahoo.com, who created this program. 

 
 
Here are the steps in greater detail: 
1. Scan the map. I used 500dpi for a DinA4-page. My example is located in Switzerland at 46°51’04”N, 9°43’25”O (= 

swiss coordinates 774245O, 191426N in http://www.swissgeo.org) out of the map 1:25.000, no 1196, named Arosa 
from the Bundesamt für Landestopographie der Schweiz. To reduce the size of this document, the qualitiy of the 



examples here is reduced. 

 
2. Import the image into Adope Photoshop.  
3. Check, whether sqares are still squares. If you have a rectangular grid printed on the map, it is quite easy. Otherwise 

(for example if the map has an UTM-grid or no grid at all) you can do the following: 
• Create a new layer (german=Ebene). 
• With the Pen-Tool (german=Zeichenstift) click on those points in the image which are square on the paper-map. 

By this you create a path. 
• In the layer-Window select the new layer, then change to the paths, select the path with the right mouse-button 

and select Stroke Path (german=Pfadkontur füllen). You get the path “printed” on the new layer. 
• Save the photoshop-document. 
• Merge the own square with the map-layer by selecting Layers -> Flatten image (german=Ebene -> Auf 

Hintergrundebene reduzieren) 
4. Now you have lines in the image which should be square although it might be not. 
5. Draw a reference square with the Rectangular Marquee Tool (Auswahlrechteck) with the aid of the info-window 

(Window -> Info). Now determine the divergence and distort the image to get the square (Edit -> Transform -> Distort, 
german=Bearbeiten -> Transformieren -> Verzerren). In case of the self-created square-lines you can fall back to the 
previous saved document and repeat the distortion of the original map with the determined values. 

6. Trim the distorted map to a rectangular shape again. (Rectangular Marquee Tool, invert selection, delete, trim image, 
german=Zuschneiden) and save the map. 

7. Determine the coordinates of the four corners of the map in the coordinate-system of the map. Calculating the 
coordinates is quite easy with Excel (see appendix) and by using the x/y-values in the info-window in Photoshop of 
known points in the map. Then transform these corner-coordinates to UTM. I like the program ALLTRANS. 
The UTM-coordinates are necessary for scaling the map and for finding the right position in MMO. 

8. Transform the coordinates of the upper left corner of the map to WGS84 longitude and latitude (again with 
ALLTRANS). This is necessary for defining your own coordinate-system within MMO. 

9. In order to get usable results out of the vectorizing process, you have to simplify the image within Photoshop. Select 
Filter -> Sharpen -> Unsharp Mask... (Filter -> Scharfzeichnungsfilter -> Unscharf maskieren…). You have to 
determine the values by yourself to get the best results for your map. Different maps may require different 



parameters. I used Stärke=500/Radius=4.0/Schwellenwert=0. 

 
10. Now the image contains a lot of small dots, each of which will generate a separate vector. 

  
So you need an image with fewer differences. This will be obtained by the filter Cutout: Filter -> Artistic -> Cutout ... 
(Filter -> Kunstfilter -> Farbpapier-Collage…). Again you have to find the best values for your specific map. I used 
Anzahl der Stufen=3/Abstraktionsgrad=0/Umsetzungsgenauigkeit=3 

 



The result is 

 
11. Perhaps you want to apply Unsharp Mask another time. This depends on your map. 
12. Convert the image to grayscale (Image -> Mode -> Grayscale) and save it as BMP without changing the parameters. 
13. Create the vector-map with WinTopo: Open the BMP-file and use Vector -> One-Touch Vectorision. You can check 

the result by toggling the BMP and vector on and off. 
Save Vector As AutoCad DXF-file. 

14. Start MMO. I use a german version of MMO. So the terms mentioned below are free translated and may differ from 
the original names. I will indicate the german expression and set my free translation in parenthesis. 
In addition the description below is based on my experiences with locations of about 48°north and 9° east (Germany, 
Switzerland). The statements may have to be translated for other regions of the world (for example the consequences 
of shifting the meridian of your own coordinate system). 

15. Set the MMO-coordinate system to UTM Optionen -> Koordinatensystem (Options -> Coordinate System) -> Univ. 
Transverse Merc. with the appropriate Zone. 

16. Select Extras -> Hintergrundkarten… (Backgroundmaps). Select „Neu erstellen…“ (Create new…). Select Layer -> 
Hinzufügen… (Add…)  

17. STOP! DO NOT open the former created vector file now. You have to create your own coordinate system first. 
18. Press the button (…) right of the displayed coordinate system. Choose Systemtyp -> Gitternetz (Grid). Choose 

Landessystem NEU (regional system -> NEW). Press the button (…) right of NEW. 
19. Type any name in the field Systemname. I used always the same system for all my work with MMO. I changed it for 

every pass-through. Perhaps you may want to preceed the name with a 0 (zero). So your name will appear on top of 
the list. Press the button (…) right of zone. 

20. Type any name in the field Name. At “Geod. Datum” choose „World Geodetic Sys. 1984”. With the button (…) you 
can display the definition of the Datum. 
At “Projektionstyp” choose “Transverse Mercator”. 
At “Lineare Einheiten” (linear units) I choosed “Meter”. 

21. Now you start an iteration process. Except for the 2. field “Maßstabsfaktor am zentralen Meridian” (Scale factor at the 
central meridian) which equals constantly 0.99600 (the value of the Transversale Mercator Projection), the other four 
values will change at each pass-through in order to meet the geographical position better and better. 

22. Start with the 1. (Länge am zentralen Meridian=Longitude at the central meridian) and 3. (Breitenursprung=Origin of 
Latitude) field as calculated in step 8. Enter 0 in the 4. and 5. field (Add.-Konstante Rechts/Hoch = add.constant 
right/up). 

23. Continue to press the Ok-button until you are at the file selection window. Switch to *-dxf-files and open the previous 
saved vector-file. 

24. As result you get two layers named 0 and 0-Fläche. As MMO does not accept these names, you have to double-click 
on the first name and change it to any word (for example Line). You can choose a colour and quit the dialogue. 



25. Enter an appropriate name in the field Kartenname (Map Name) and press the button “Karte erstellen” (create map). 
Save the entered information and quit the window. 

26. You will find you created map listed in the window of Hintergrundkarten (Backgroundmaps). Press Schließen (Close). 
27. You should see your vectorized map displayed in MMO. If not zoom in until the scale-factor is less than the value you 

set when creating the map (usually 1:100.000). 
28. Zoom into the upper left corner. Measure the most left and most upper end of vectors in the upper left corner (usually 

there will be no exact point in the corner). So you get the actual UTM-coordinates of this corner.  
29. In this step, you will determine the distance your map has to be shifted in MMO to match the real coordinates. You 

can do this by entering the known values into the Excel-sheet in the appendix, fields A, B – D, J – L (the actual values 
of your coordinate system in MMO), R – S (the values you just read out of MMO), Z-AG (the values, the map has in 
reality), AJ(the value indicated by Photoshop(Image -> Image Size, Width in pixels), AN, AO (the actual values of 
your coordinate system in MMO). 
AP and AQ indicate the values the map has to be shifted, i.e. the values for the 4. and 5. field of the coordinate-
system in MMO for the next pass-through. 

30. Repeat the steps 16 to 29 (of course by reusing the map and coordinate system instead of creating new ones), until 
the Excel-Fields AL and AM are reasonable small (<10m), i.e. the UTM-coordinates of the imported map are less than 
10m away from reality. 

31. Measure out the UTM-values of the right upper corner in MMO and enter the values in Excel-columns T and U. You 
will find that the dimensions of the vector map are too small or too large. In Column AK you get indicated the number 
of pixels, you have to enter in Photoshop to resize the BMP-image. 
After resizing the image, regenerate the DXF-file with WinTopo. 

32. Repeat step  16 to 29 with the new vector-map until the UTM-difference of the upper left corner is reasonable small.  
33. By entering the UTM-coordinates of the remaining three corners in Excel you will find, that they don’t meet the real 

values. To correct this, you have to shift den zentralen Meridian (the central meridian) and den Breitenursprung (the 
origin of Latitude), i.e. the fields 1 and 3 in your own coordinate system in MMO while importing the vector file. 
 
The consequences of shifting these two parameters are:  
The upper left corner is considered as matching the reality. Then 
• If the central meridian is situated too far east, the eastern edge of the map will rise too high 
• If the central meridian is situated too far west, the eastern edge of the map will sink too low. 
• If the origin of latitude is situated too far north, the lower edge of the map will be shifted too far right. 
• If the origin of latitude is situated too far south, the lower edge of the map will be shifted too far left. 

34. For the next import you have to shift the 1. and 3. field of your coordinate system in the way, indicated by the above 
rules. For example if the right edge of your map is too high, shift the 1. field about one degree west. After several 
passes-through, if the upper left corner matches again, hopefully the right edge will be too low. Now you can use the 
Excel-columns F-I and N-Q (copy the formula of the filled-out cell in column F and N to the row you need). They 
calculate the average between the position of too high and too low and give you a suggestion where to position the 
Latitude and Longitude of your own coordinate system in MMO while importing, in order to get the right and lower 
edge of your map positioned well. 



The result will be a map in MMO like the following: 

  
35. Export the map from MMO: Datei -> zum GPS übertragen -> Hintergrundkarte -> Speichern auf Festplatte (File -> 

transfer to GPS -> Backgroundmap -> Save to disk). 
As the files produced by MMO 1.10 are not usable with Meridian-GPS, they must be converted by the program 
convertMMOoutput.exe. 
That output can be copied to the SD-card and activated by the Meridian. 



36. Here are the screenshots of my Meridian Platinum corresponding to the example above: 

 
 
Attachments: 
• Vector-Map of  the area of Fideris (CH) out of a DIN A4-scan of a map 1:25.000 with an accuracy of 1 to 4 m. Source 

paper map see step 1 above. 
• Vector-Map of  the area of Fideris (CH) out of a DIN A4-scan of a map 1:50.000 with an accuracy of 1 to 4 m. 
• Excel-sheet for calculating the own coordinate system 

Translation: links=left, rechts=right, Ost=east, Vorschlag=suggestion, oben=upper, unten=lower, Ist=actual value, 
Soll=planned value, Delta=difference between two values, Länge=length 

• Example input-file for ALLTRANS 
 
Questions: 
• Does anybody native english speaking person like to improve the English of this document? By the way, the correct 

English expressions of MMO could be inserted. 
• Does anybody know a place where to post generated maps? Perhaps someone else wants to go hiking in Bavaria, 

Austria or Switzerland and find the maps useful. 


